Error message - 'Input string was not in a correct format'

Using the SPSolutions/Delegation/AddDelUser.aspx page, I receive the following error message after adding a new user to a site.  The user is added, but the message appears:

Input string was not in a correct format.   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
   at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
   at SPSolutions.SharePoint.Delegation.ApplicationPages.DelegationAclPage.get_GroupId()
   at SPSolutions.SharePoint.Delegation.ApplicationPages.AddDelUserPage.FinishButton_Click(Object sender, EventArgs args)
   at System.Web.UI.WebControls.Button.OnClick(EventArgs e)
   at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Thank You

Have more questions? Submit a request


  • 0
    Matthew McBride

    Did you selected a Group in the Give Permission section of the AddDelUser.aspx page? Can you provide the inputs provided to produce this error message? 

    Jeremy Luerkens
    Manager, Software Production
    SharePoint Solutions
  • 0
    Matthew McBride

    No.  I selected the 'Give user permission directly' option.


  • 0
    Matthew McBride

    I found the solution.  We're not using SharePoint groups and have removed them all to avoid confusion.  The message is displayed when there are no groups in the Groups dropdown,   After adding a single group, the error message disappears.

Please sign in to leave a comment.